Forum Discussion

SuperG's avatar
New Contributor
11 years ago

Authentication / SoupUI

I am very new with web services or at least WCF web services. I have been successfully using SOAPUI to test our WCF web service until I had the requirement to enable BASIC security on the service. When I try to execute the service after enabling BASIC authetication I get a blank screen for the result. If I enter the wrong username/password it will return a message in the result pane that I entered the incorrect password. I am not sure what to do.

I tried the following
1. Checking the box for Authenticate Preemptively
2. I have tried every authentication type within the AUTH tab on the request.

I have verified through another application that the authentication is working, but I cannot get results to display in SOAP UI

3 Replies

  • GiscardN's avatar
    Frequent Contributor

    WCF web services turn on wsHttpBinding by default. wsHttpBinding turns on a number of WS-* protocols by defaults. Some of them we support, such as:
    WS-Security, WS-Addressing and WS-ReliableMessaging.
    But there are other standards used in wsHttpBinding that are not supported by SoapUI Pro (e.g. WS-SecureConversation, WS-SecurityPolicy).
    Our clients that test WCF web services would usually change to BasicHttpBinding. Then you can configure SoapUI Pro as described in the following article: ... t-one.html


    SmartBear Support
    • marko's avatar
      New Contributor


      We are using certificate validation as security measure for web service that we have built
      Now we are facing technical problem that is preventing us from using SoapUI anymore. 
      There is no way to force SoapUI to use certificates to validate access to our web service call. 
      We were testing this web service and certificate authentication is working when we run it from our code or other tools like WCF test client.
      Our service is using standard WCF wsHttpBinding and we found some blog posts on the web that soap UI cannot work with that kind of binding.
      Is this true ? If this is true, than we have to stop using your product. 
      We have followed this procedure with no success : 
      we have tried even older versions, and it is not helping at all : 
      The same message that we are getting again and again : 
      <s:Text xml:lang="en-US">The message could not be processed. This is most likely because the action '' is incorrect or because the message contains an invalid or expired security context token or because there is a mismatch between bindings. The security context token would be invalid if the service aborted the channel due to inactivity. To prevent the service from aborting idle sessions prematurely increase the Receive timeout on the service endpoint's binding.</s:Text>
      Can you please advise if you have any solution for this issue. 


  • SuperG's avatar
    New Contributor
    Well, I made a rookie mistake. I thought i could just add the username/password to an existing project but I didn't realize that some of the bindings changed. I had to save the WSDL file and setup a new project and everything is working as expected.