Forum Discussion

kratosis's avatar
Regular Visitor
2 years ago

Test run creation request creates a test run but doesn't add any test

Hello everyone! My problem is that I've tried to use Cucumber Studio API and as I suppose I did it in the wrong way. I've tried to create a test run with a bunch of test using command. That's how it looks like

Body : {"data":{"attributes":{"name":"XXXXXXXX","description":"Pls work","scenario_ids":[37372314,37372316,37372317]}}}
Headers : (5)
Accept : application/vnd.api+json; version=1
access-token : XXXXXXXXXXXX
Content-type : application/json

And it creates a test run but it looks like

As well I tried update command but it works the same way.
The server answer with a positive code 201 and tells me that everything is OK

[Success: {"data":{"id":"XXXXXXX","type":"test-run","attributes":{"created-at":"2023-02-06T09:41:13.126Z","updated-at":"2023-02-06T09:41:13.126Z","last-author":"XXXXXXXXXX","name":"XXXXXXXXXXXXXX","description":"Pls work","statuses":{},"archived":false,"external":false},"relationships":{"tags":{}},"links":{"self":"/test-runs/XXXXXX"}}}]

What am I doing wrong?

No RepliesBe the first to reply