Forum Discussion

nifengfei's avatar
Occasional Contributor
14 years ago

AQtime cannot launch

Hi experts,

I try to install AQtime(version 6.50.498.86) on my machine, the machine is Dell P980, and the os is Microsoft windows 7 Enterprise, 32 bit. the installation process is good. but after it, i try to launch it, also, the AQtime UI can display, but if i just click it, AQtime will become "no responding" status, it hangs there and you cannot do anything until it crashes.

I have tried to re-install or repair it, but still doesn't work, could you help me on it? thanks a lot.


6 Replies

  • Hi feng,

    Please try running AQtime 6 with the /ns command-line argument. For example, you can use the following command line:

    "C:\Program Files\Automated QA\AQtime 6\Bin\AQtime.exe" /ns

    If this does not help, please follow the steps below:

    1. Download the Debugging Tools for Windows package from here and install it.

    2. When AQtime 6 hangs, open the "Start | Run..." dialog and execute the following command:

    "C:\Program Files\Debugging Tools for Windows (x86)\windbg.exe" -pn AQtime.exe -Q -pd -c ".dump /m C:\Dump1.dmp;q"

    This command will make WinDbg write a memory dump of the AQtime.exe process to the "C:\Dump1.dmp" dump file. After the dump is written, WinDbg will be closed.

    3. Correct the dump file name in the above command line (for example, change it to Dump2.dmp), wait for two minutes and execute the command again.

    4. Repeat step 3.

    5. Send us all of the generated dump files.
  • nifengfei's avatar
    Occasional Contributor
    hi Lexi,

    thanks for your help. the command line works! but could you please tell me why? and each time, i have to use the command line to start AQtime, not that convinient. any more solutions, thanks. 
  • Hi,

    You have faced a problem introduced by some recent Windows updates. At some point, Microsoft released an update (we don't know yet which one and when it was released) that changed some basic OS functionality. Looks like this update was released for all OS versions starting from Windows XP. As a result, some users are observing such hangings at random places. This does not happen for every PC, but if it happens, it occurs constantly on this specific computer.

    We have reproduced the problem in our lab and managed to work around it. A fix for the issue will be included in the next AQtime 7 update. However, there are no updates planned for version 6. So, the only reliable solution, besides launching AQtime with the /ns command-line argument, is to upgrade to version 7 after the next product update is released. Alternatively, you can try installing a clean Windows copy without any updates - this should help you avoid the hanging.

    In the meantime, to avoid running AQtime 6 via the command line every time, you can modify its command line in its shortcut properties:

    1. In the Windows Start | All Programs menu, find the AQtime's shortcut (AutomatedQA | AQtime 6 | AQtime 6).

    2. Right-click the shortcut and choose Properties from the context menu.

    3. In the ensuing dialog, add the /ns string to the Target text box.

    4. Click OK to save the changes.

    5. Run the tool using the modified shortcut.
  • nifengfei's avatar
    Occasional Contributor
    thanks,it is ok to add the /ns in the startup shortcut.
  • dwynne's avatar
    New Contributor
    I am having the same problem with AQTime 6.50.498.64 running on Windows Server 2008 r2 x64.  The /ns command line seems to fix it as well.

    What does that do and do we miss anything using that option?  Any update or fix available?

  • Hi,

    The /ns parameter just disables the splash screen. This doesn't affect any other functionality.

    As for fixes, AQtime 6 is no longer developed, and no fixes for it are planned. Try using the latest AQtime version (7.20).