Ask a Question

Swagger UI returning 500 with new version

von_schytte
New Contributor

Swagger UI returning 500 with new version

Hi

We are using the swagger UI POST /debug service to validate our swagger documents. However lately we have started to get an internal server error (code 500) rather than the normal response (code 200 + any validation errors)

I have tried the same swagger doc in the swagger editor which works fine. Here is an example with intentional errors, that returns an internal error in swagger UI:

{
"swagger":"2.0",
"info":
{
"version":"2.0.0",
"title":"Beanhunter API",
"description":"Description of the api goes here."
},
"host":"local.xxx.com",
"schemes":["http"],
"consumes":["application/json"],
"produces":["application/json"],
"paths":
{
"/city":
{
"get":
{
"description":"test description"
}
}
},
"definitions":
{
"Endpoints":
{
"title":"Endpoints object","properties":
{
"links":{}
}
}
}

 

Any ideas?

 

Thanks

- Jakob

2 REPLIES 2
tsoenen
Visitor

Re: Swagger UI returning 500 with new version

I noticed the same. This issue only appears for Openapi 2.0 specifications. Apenapi 3.0 still works fine. Maybe support for 2.0 has been disabled?

von_schytte
New Contributor

Re: Swagger UI returning 500 with new version

Well it seems to be working now

cancel
Showing results for 
Search instead for 
Did you mean: