cancel
Showing results for 
Search instead for 
Did you mean: 

soapui-mavein-plugin-5.1.3 not working?

SOLVED
Highlighted
New Contributor

soapui-mavein-plugin-5.1.3 not working?

Hi all,

I've upgraded SOAPUI from 5.0.0 to 5.1.3. while in 5.0, everything was working fine, including executing my tests from jenkins using teh soapui-maven-plugin-5.0.0.

 

When I upgraded to plugin 5.1.3, I got the following error:

 

[ERROR]  Plugin com.smartbear.soapui:soapui-maven-plugin:5.1.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.smartbear.soapui:soapui-maven-plugin:jar:5.1.3: Failure to find com.smartbear.soapui:soapui-project:pom:5.1.3 in http://www.soapui.org/repository/maven2/ was cached in the local repository, resolution will not be reattempted until the update interval of smartbear-sweden-plugin-repository has elapsed or updates are forced -> [Help 1]

For now, I was able to downgrade my plugin to version 5.1.1 and have it working. but would like to know when this is fixed so I can sync my plugin and soapui versions.

 

thanks,

marcelo.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Staff

Re: soapui-mavein-plugin-5.1.3 not working?

For some reason the pom file was missing in our public repository. I have uploaded the missing file now. You could retry with the -U flag to force a refetch of the file.

Regards
Joel Jonsson
SmartBear Stockholm Developer

View solution in original post

4 REPLIES 4
Highlighted
Staff

Re: soapui-mavein-plugin-5.1.3 not working?

For some reason the pom file was missing in our public repository. I have uploaded the missing file now. You could retry with the -U flag to force a refetch of the file.

Regards
Joel Jonsson
SmartBear Stockholm Developer

View solution in original post

Highlighted
New Contributor

Re: soapui-mavein-plugin-5.1.3 not working?

Thanks Joel!

 

I tested and is working great!

 

Regards,

Marcelo.

Highlighted
New Member

Re: soapui-mavein-plugin-5.1.3 not working?

its still not working for me I tried the given solution

 

"Project build error: Non-resolvable parent POM for com.smartbear.soapui:soapui-maven-plugin:[unknown-version]: Could not find artifact com.smartbear.soapui:soapui-project:pom:5.1.3 in central (https://repo.maven.apache.org/maven2) and 'parent.relativePath' points at wrong local POM"

 

can any one help me out with this ????


@mscaldas wrote:

Hi all,

I've upgraded SOAPUI from 5.0.0 to 5.1.3. while in 5.0, everything was working fine, including executing my tests from jenkins using teh soapui-maven-plugin-5.0.0.

 

When I upgraded to plugin 5.1.3, I got the following error:

 

[ERROR]  Plugin com.smartbear.soapui:soapui-maven-plugin:5.1.3 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.smartbear.soapui:soapui-maven-plugin:jar:5.1.3: Failure to find com.smartbear.soapui:soapui-project:pom:5.1.3 in http://www.soapui.org/repository/maven2/ was cached in the local repository, resolution will not be reattempted until the update interval of smartbear-sweden-plugin-repository has elapsed or updates are forced -> [Help 1]

For now, I was able to downgrade my plugin to version 5.1.1 and have it working. but would like to know when this is fixed so I can sync my plugin and soapui versions.

 

thanks,

marcelo.


 

Highlighted
Occasional Contributor

Re: soapui-mavein-plugin-5.1.3 not working?

I saw there is a recent change in soapui maven repository. And due to that I am getting similar error 

Failed to execute goal com.smartbear.soapui:soapui-maven-plugin:5.3.0:test (api-report) on project project-api: Execution api-report of goal com.smartbear.soapui:soapui-maven-plugin:5.3.0:test failed: Plugin com.smartbear.soapui:soapui-maven-plugin:5.3.0 or one of its dependencies could not be resolved: The following artifacts could not be resolved: xmlbeans:xbean:jar:fixed-2.4.0, jetty:jetty:jar:6.1.26, jetty:jetty-util:jar:6.1.26, commons-ssl:not-yet-commons-ssl:jar:0.3.11, json:json-lib:jar:2.2.2-jdk15, bouncycastle:bcprov-jdk15:jar:144, l2fprod:l2fprod-common-directorychooser:jar:7.3, com.btr:proxy-vole:jar:20131209, javafx:jfxrt:jar:2.2: Could not find artifact xmlbeans:xbean:jar:fixed-2.4.0 in SmartBearPluginRepository (http://www.soapui.org/repository/maven2/)

It is the same error while running mvn clean test -U. 

Can you please check it whether any update is missing or not !!!

Thanks


New Here?
Join us and watch the welcome video:
Top Kudoed Authors