cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable TLSv1.2 for Testrunner

SOLVED
Highlighted
New Contributor

How to enable TLSv1.2 for Testrunner

I have configured the vmoption file. Its working fine when i trigger request directly using play button. But while same testcase fails when I

ran through Testrunner with SSLhandshake error. Please let me know if there is any configuration to be done Testrunner to support tlsv1.2
Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: How to enable TLSv1.2 for Testrunner

  • Close SoapUI if running.
  • Go to SOAPUI_HOME/bin directory
  • Have a backup of testrunner.bat/.sh file depending on the OS
  • Open the file in a text editor of your choice
  • Locate line containing set JAVA_OPTS
  • Add the below line there

set JAVA_OPTS = %JAVA_OPTS% -Dsoapui.https.protocols=TLSv1.2

  • Save the file

Now you should be able use TLSv1.2.



Regards,
Rao.

View solution in original post

2 REPLIES 2
Highlighted
Community Hero

Re: How to enable TLSv1.2 for Testrunner

  • Close SoapUI if running.
  • Go to SOAPUI_HOME/bin directory
  • Have a backup of testrunner.bat/.sh file depending on the OS
  • Open the file in a text editor of your choice
  • Locate line containing set JAVA_OPTS
  • Add the below line there

set JAVA_OPTS = %JAVA_OPTS% -Dsoapui.https.protocols=TLSv1.2

  • Save the file

Now you should be able use TLSv1.2.



Regards,
Rao.

View solution in original post

Highlighted
New Contributor

Re: How to enable TLSv1.2 for Testrunner

Thanks it worked 👍👍👍👍👍
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors