cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable TLS 1.2 in SoapUI

SOLVED
Highlighted
Community Hero

Re: How to enable TLS 1.2 in SoapUI

  1. Go to SOAPUI_HOME/bin
  2. Take backup of soapui.bat/.sh depnding on your OS platform, in case you want to revert the change quickly later.
  3. Open the above file, and locate JAVA_OPTS, then you can add another line

for eg:

//windows
set JAVA_OPTS=%JAVA_OPTS% "-Dsoapui.https.protocols=SSLv3,TLSv1.2"

//unix
export JAVA_OPTS=$JAVA_OPTS "-Dsoapui.https.protocols=SSLv3,TLSv1.2"

Then save the changes, then rest soapUI if it is already running.



Regards,
Rao.
Highlighted
New Contributor

Re: How to enable TLS 1.2 in SoapUI

I've performed the steps outlined in this thread, however, this does not appear to work with SoapUI 5.2.1.  I'm still getting "handshake_failure".  The log file is quite lengthy, however, I'd be glad to attach it if necessary.

Highlighted
Community Hero

Re: How to enable TLS 1.2 in SoapUI

I would suggest to open a topic (rather than reviving old resolved one) with all the required details. And should be a problem to attach a zip file if you want to upload logs.


Regards,
Rao.
Highlighted
Occasional Visitor

Re: How to enable TLS 1.2 in SoapUI

Your syntax seems to be off slightly, the double quote character is not positioned correctly. I have just enabled TLS 1.1 for my client by adding the following to my .bat file:

 

set JAVA_OPTS=%JAVA_OPTS% -Dsoapui.https.protocols="SSLv3,TLSv1.2"

 Please note the " character is AFTER the =, wrapped around the value of the protocols, and NOT before the - (dash).

 

Doublechecked, the above really works.

Highlighted
Occasional Visitor

Re: How to enable TLS 1.2 in SoapUI

Has anyone enabled TLS 1.2 on OSX 10.11 successfully?
Highlighted
New Member

Re: How to enable TLS 1.2 in SoapUI

The default install location for Mac is in the root Applications folder, and the vmoptions.txt file is in there.  Something like:

 

/Applications/SoapUI-X.X.X.app/Contents/vmoptions.txt

 

 

You can add the -Dsoapui.https.protocols=TLSv1.2 line there.

 

Worth noting that you have to either go through a terminal to get there, or choose "Show Package Contents" in the /Applications folder to get to the internal files.

Highlighted
New Member

Re: How to enable TLS 1.2 in SoapUI

Place this in your SoapUI-X.Y.Z.vmoptionsf file (where X.Y.Z is the version number of SOAPUI you have)

 

-Dsoapui.https.protocols=TLSv1.2,SSLv3

 

 

 

The above worked for me on v5.2.0.

 

Adios,

Adi

Highlighted
New Contributor

Re: How to enable TLS 1.2 in SoapUI

AT's method works. 

Default windows location of the file he mentions is in [InstallDirectory]\bin\

 

So for me for example it was: 

C:\Program Files\SmartBear\SoapUI-5.2.1\bin\SoapUI-5.2.1.vmoptions

 

Add following line and restart. 

 

-Dsoapui.https.protocols=TLSv1.2,SSLv3

The .bat option by nmrao above helps if you need multiple startup options. i.e. some servers might not support TLS 1.2... (shame on them really, but ok) 

Highlighted
Occasional Visitor

Re: How to enable TLS 1.2 in SoapUI

I use SoapUI 5.2.1 and I'v tried to set the above parameters (-Dsoapui.https.protocols=SSLv3,TLSv1.2).

But it doesn't work 😞

Got handshake_failure!

And the webservices which I need to connect only accept a connection established via TLS 1.2. 

Anyone can help please?

Highlighted
Occasional Visitor

Re: How to enable TLS 1.2 in SoapUI

I recently had the same problem with SoapUI 5.2.1 on OS X.  I tried everything discussed on the forums: made sure to use the correct JRE; added -Dsoapui.https.protocols=TLSv1.2 to vmoptions; tried the "-Dsoapui.https.ciphers=" option with the exact configuration the browser was successfully using to connect to the server; made sure I was using the Unlimited JCE Policy Update in the JRE.... nothing worked.  Same SSL handshake error.

 

So, I decided to try the snapshot build of SoapUI 5.2.2 (https://github.com/SmartBear/soapui/) and that worked properly without any tweaking.  (It did take some effort to actually get it to build successfully on my machine, but that's a separate topic)

 

Hope that helps, and hope the community and Smart Bear continue development on the open source version.

New Here?
Join us and watch the welcome video:
Top Kudoed Authors