Ask a Question

SoapUI 5.6.0 upgrade keeps JRE 8 : java.lang.UnsupportedClassVersionError

New Contributor

SoapUI 5.6.0 upgrade keeps JRE 8 : java.lang.UnsupportedClassVersionError

When I started SoapUI 5.5.0 today, an upgrade to 5.6.0 was offered.

However, after the upgrade, SoapUI doesn't start; it fails with this error:


java.lang.UnsupportedClassVersionError: com/eviware/soapui/SoapUI has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0


I checked the jre contained within SoapUI; it is still "1.8.0_181", but obviously at least Java 9 is required.


I'm on Ubuntu 18.04.4 LTS.

New Contributor

Copying a more recent JRE (Java 11) into the jre subfolder (as suggested here) fixed it.

I confirm that this solved the issue also for me (SO: Ubuntu 20.04). I used AdoptOpenJDK11 and it worked.

Hi i'm having the same trouble but i cant find the jre subfolder inside of ~/SmartBear/SoapUI-5.6.0/, in wich directory i have to search?

hi @jmordonez 


I have a jre as a child of my parent SoapUI folder (i.e. C:\Program Files\Smartbear\SoapUI-5.6.0\jre) but I'm running windows.


What operating system are you running?



rather than mess about with directories you could just install java properly instead?  that would save all the hassle....






if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

@richie thanks for the answer


I'm running on Ubuntu


My java version is:

openjdk version "1.8.0_272"
OpenJDK Runtime Environment (build 1.8.0_272-8u272-b10-0ubuntu1~20.04-b10)
OpenJDK 64-Bit Server VM (build 25.272-b10, mixed mode)


I downloaded the file from 

Then i assigned execution permisses and ran it

The installation finished without problems but when i wanted to open it the java.lang.UnsupportedClassVersionError shows up


I still don't able to find the jre folder.


Thanks for your time!

Hi I fixed it installing the latest jdk available of OpenJDK with the command sudo apt install default-jdk, wich installed jdk 11, this made think the problem was my previous java version (1.8.0_272)



Showing results for 
Search instead for 
Did you mean: