Ask a Question

Is there a way to trigger SmartBear's attention? Why/when is a script considered maliscious?

Frequent Contributor

Is there a way to trigger SmartBear's attention? Why/when is a script considered maliscious?

About a month ago I posed a question in this forum because SOAPUI refuses to execute certain load-scripts claiming that they contain maliscious code - see

Unfortunately nobody responded so far. Is there a way to trigger SmartBear's attention to provide a response to this?


WHY or WHEN does it consider a script "maliscious"? Are there any rules or some description explaining what causes this or what one needs to avoid in a script to not be flagged as "maliscious"?

Community Hero

Hey @mmoser18 


Unfortunately the short answer is "no".


If you were using the licensed ReadyAPI, then you'd be able to submit customer support tickets - this is one of my peeves with the SmartBear/SoapUI situation, SmartBear have pretty much washed their hands of anything to do with the open source SoapUI option.


If you have a query or problem relating to SoapUI, you're reliant on the good graces of the people on this forum and on others like stackoverflow - however - if no one answers your queries, there's literally no where to go.


SmartBear as far as I can tell don't support SoapUI at all in any way.  It's completely rubbish when you've exhausted the forum options - cos those are the only options available.


I remember the post you submitted, but didn't know enough about it to even provide an opinion,  I've just looked in the Preferences for anything related to Load Scripts, Mocking, malicious code, privileges and I could find a two switches that are related to Load Scripts/Mocking but nothing that really appears to match what was hinted at in the error response.


The only tiny bit of advice that's almost next to worthless is to compare your SoapUI instance's 'System Properties' and 'Preference' settings against your colleagues and see if you have any differences that might help.  the fact that this malicious code warning has just appeared recently doesnt give me much hope you'll find anything, other than perhaps another completely separate component within your system has been updated without your knowledge and this has somehow impacted things (which I kinda doubt)


I did google 'soapui malicious code mock load script' and variations of to see if there have been any historical posts raised like from way back when (2015 or earlier) - but zero relevant pages were returned - so I'm afraid I just got nothing for you to follow up.


It's crossed my mind before in similar situations about whether the SoapUI dev contributors could help.  They do knock out an update once in a while, but the releases appear to be few and far between and the number of changes in each release seem to be diminishing so I dont even think sending of them a message on git would help at all.


Sorry I couldn't be of more help,





if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Champion Level 3

Hi @mmoser18 ,

as far I understand, Smartbear supports SoapUI OS in several ways:

  • hosts this forum and moderates it
  • hosts and maintains the download pages, documentation etc.
  • I believe there are also other areas

On the other hand SoapUI is a community project and Smatbear does not take the full responsibility.

You can:

  • check the documentation
  • ask in the forum (and contribute as well)
  • check the source code (and contribute as well)

In case you need a guaranteed support you need to buy ReadyAPI licence.


Anyway, I believe a clear statement from Smartbear would be helpful, since it's not clear to many people.


Best regards,

Frequent Contributor

@richieand @KarelHusa: Thanks for your response and the effort you have put into it! Appreciated!

Showing results for 
Search instead for 
Did you mean: