Ask a Question

Got a validation error.

cloris19910410
Occasional Visitor

Got a validation error.

Hi,

 

 I try to validate a soap message, but it always show me an error : line -1: null...

I really don't understand what it means. Can anyone help me with this?

Below is my soap message.  Thanks!

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:user="http://userprofile.esm.dteco.com/v1/userprofileresponses" xmlns:v1="http://esm.dteco.com/common/v1">
   <soapenv:Header/>
   <soapenv:Body>
      <user:UpdateUserProfileResponse>
         <v1:Header>
            <v1:Verb>change</v1:Verb>
            <v1:Noun>?</v1:Noun>
            <!--Optional:-->
            <v1:Channel>NWB</v1:Channel>
            <!--Optional:-->
            <v1:Transaction>?</v1:Transaction>
            <!--Optional:-->
            <v1:Revision>?</v1:Revision>
            <!--Optional:-->
            <v1:Context>DEVELOPMENT</v1:Context>
            <!--Optional:-->
            <v1:Timestamp>2015-07-08T07:39:18-04:00</v1:Timestamp>
            <!--Optional:-->
            <v1:Source>?</v1:Source>
            <!--Optional:-->
            <v1:AsyncReplyFlag>true</v1:AsyncReplyFlag>
            <!--Optional:-->
            <v1:ReplyAddress>?</v1:ReplyAddress>
            <!--Optional:-->
            <v1:AckRequired>true</v1:AckRequired>
            <!--Optional:-->
            <v1:User>
               <v1:UserID>?</v1:UserID>
               <v1:Organization>?</v1:Organization>
            </v1:User>
            <!--Optional:-->
            <v1:MessageID>?</v1:MessageID>
            <!--Optional:-->
            <v1:CorrelationID>?</v1:CorrelationID>
            <!--Optional:-->
            <v1:Comment>?</v1:Comment>
            <!--Zero or more repetitions:-->
            <v1:Property>
               <v1:Name>?</v1:Name>
               <!--Optional:-->
               <v1:Value>?</v1:Value>
            </v1:Property>
            <!--You may enter ANY elements at this point-->
         </v1:Header>
         <v1:Reply>
            <v1:ReplyCode>SUCCESS</v1:ReplyCode>
            <!--Zero or more repetitions:-->
            <v1:Error>
               <v1:level>INFORM</v1:level>
               <v1:code>?</v1:code>
               <!--Optional:-->
               <v1:xpath>?</v1:xpath>
               <!--Optional:-->
               <v1:details>?</v1:details>
               <!--Optional:-->
               <v1:context>?</v1:context>
            </v1:Error>
            <!--Zero or more repetitions:-->
            <v1:ID>?</v1:ID>
            <!--You may enter ANY elements at this point-->
         </v1:Reply>
      </user:UpdateUserProfileResponse>
   </soapenv:Body>
</soapenv:Envelope>
2 REPLIES 2
TanyaYatskovska
Community Manager

Re: Got a validation error.

Hi,

 

Did you try adding the XML version to the message? For example:

<?xml version="1.0"?>

 

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
nmrao
Community Hero

Re: Got a validation error.

There can be multiple reason in general when a request fails validation.
1. request is not complying to the schema / wsdl
2. wsdl /schema could have problems
3. some times there could be special characters that can be seen by naked eye, may try to seen in an editor where you can see all the special characters and place the soap request and try validating it. Of course, sometimes empty spaces could also cause issue when they are at unwanted place.
Check it out.


Regards,
Rao.
cancel
Showing results for 
Search instead for 
Did you mean: