Ask a Question

Bug: soapui-maven-plugin:5.2.1 + IBM JDK 1.7: Could not find artifact javafx:jfxrt:jar:2.2

puce
New Contributor

Bug: soapui-maven-plugin:5.2.1 + IBM JDK 1.7: Could not find artifact javafx:jfxrt:jar:2.2

For some reasong soapui-maven-plugin:5.2.1 looks for JavaFX (why?). AFAIK, the IBM JDK does not ship JavaFX, however.

 

I'm getting the error:

 

Execution soapUI-tests of goal com.smartbear.soapui:soapui-maven-plugin:5.2.1:test failed: Plugin com.smartbear.soapui:soapui-maven-plugin:5.2.1 or one of its dependencies could not be resolved: Could not find artifact javafx:jfxrt:jar:2.2 at specified path [...]

 

It works with version 4.6.1, but then I'm getting the following warning:

 

Project 'application' is from a newer version (5.2.1) of SoapUI than this (4.6.1) and parts of it may be incompatible or incorrect. Saving this project with this version of SoapUI may cause it to function differently.

 

Please also note that it's not very clear from the documentation which version we should use: https://www.soapui.org/test-automation/maven/maven-2-x.html

3 REPLIES 3
rupert_anderson
Valued Contributor

Hi,

 

I think the jfxrt / JavaFX is required to enable part of the OAuth 2 support, maybe the part that opens a browser to obtain a refresh token.  

 

I think you have to use the Oracle JDK - I'm not sure if this is written anywhere. I had the same jfxrt error when using Open JDK on Ubuntu, I chose to get the Oracle JDK to solve it, but I guess you could remove the depency instead if you don't need the OAuth functionality. I expect 4.6.1 predates the OAuth2 support.

 

Regards,

Rupert

Author of SoapUI Cookbook

As our application will be deployed to WebSphere, we have to use the IBM JDK 1.7.

 

How can I remove the dependency from the plugin?

Ok, I guess thats an issue if SoapUI's running on the same machine and you haven't got a VM (with a Oracle JDK handy).

 

I saw two work-arounds discussed involving modifying the pom to either, add the jfxrt.jar from a local file path or exclude it from the dependencies - please see:

 

http://community.smartbear.com/t5/SoapUI-NG/Maven-Build-Failing-Following-Upgrade-to-5-0-0/td-p/4041...

 

Regards,

Rup

Author of SoapUI Cookbook
cancel
Showing results for 
Search instead for 
Did you mean: