Ask a Question

importing the authentication protected wsdl in v4.6.4

payam
Contributor

importing the authentication protected wsdl in v4.6.4

When trying to import an authentication-protected wsdl (some thing like http://10.11.12.13:9626/getWSDL we get an error reponse:

Error loading [http://10.11.12.13:9626/getWSDL]: org.apache.xmlbeans.XmlException: java.io.IOException: Server returned HTTP response code: 401 for URL: http://10.11.12.13:9626/getWSDL


However, there was an authentication window popping up in earlier windows. We have to downgrade again
9 REPLIES 9

Re: importing the authentication protected wsdl in v4.6.4

Hi,

What was the previous version of SoapUI Pro you were using in which you received a pop up window to authenticate? Can you show a screen shot of this authentication window?




Regards,
Marcus
SmartBear Support
payam
Contributor

Re: importing the authentication protected wsdl in v4.6.4

This is what I can see from not a very older version (4.6.3 free)

I can see this using soapui pro 4.6.4
payam
Contributor

Re: importing the authentication protected wsdl in v4.6.4

sorry I meant I can NOT see this window in 4.6.4 pro

Re: importing the authentication protected wsdl in v4.6.4

Hi!

Have you tried using preemptive authentication by filling out your credentials in the Auth tab on the request view?
See http://www.soapui.org/SOAP-and-WSDL/aut ... uests.html for reference.

--
Regards

Erik
SmartBear Sweden
payam
Contributor

Re: importing the authentication protected wsdl in v4.6.4

How can I do it when I'm not even able to import the wsdl?

Re: importing the authentication protected wsdl in v4.6.4

Hi again!

You are absolutely right, my previous post is obviously not applicable in your situation, sorry for that.
We've verified that this indeed a bug in the latest version of SoapUI and have registered an issue for it in our internal bug tracker (SOAP-1331).

We'll let you know as soon as we have more information about this.

--
Regards

Erik
SmartBear Sweden

Re: importing the authentication protected wsdl in v4.6.4

Hi

This problem is now solved and the fix is accessible through our maintenance builds at http://www.soapui.org/Downloads/soapui- ... uilds.html
Thanks for reporting the problem and helping us improve SoapUI!

Regards
Joel Jonsson
SmartBear Sweden
royhiggs
New Member

Re: importing the authentication protected wsdl in v4.6.4

 I think this is broken again in 5.4.0. I'm not getting prompted for credentials. 

eugenezadorin
Occasional Visitor

Re: importing the authentication protected wsdl in v4.6.4

Try to inspect HTTP headers your API-server responds with.

 

According to MDN schema - https://developer.mozilla.org/en-US/docs/Web/HTTP/Authentication - server must send WWW-Authenticate header which tells client how exactly to authorize.

 

In my case when I've been added following header: 

 

WWW-Authenticate: Basic realm="My super api", charset="UTF-8"

 

And Soap UI shows me credentials popup. Tested at v5.4.0.

cancel
Showing results for 
Search instead for 
Did you mean: