Ask a Question

error when importing a postman collection

Occasional Contributor

error when importing a postman collection

I tried to import a postman collection (JSON format) in SoapUI/ ReadAPI, but I encounter the following error:


net.sf.json.JSONException: JSONObject["requests"] is not a JSONArray


Can someone please help me?




This is what they have replied for the issue :-


Thank you for reaching out.

I tried it on my end and this seems a bug. I have logged it. Unfortunately, there isn't a workaround for this bug.

The JIRA# is RIA-6725.


I have a comment on RIA-6725. According to the documentation - .


ReadyAPI currently supports only v1 collections and does not support v2 collections. So, RIA-6725 was converted to improvement request RIA-6640. 

Export collection as V1 option. it works though deprecated.

New Contributor

I found a workaround by exporting the Postman Collection as Collection v1 (deprecated). However, authorization credentials are not imported in this way and you have to manually enter and save them in Soap UI requests.


I've encountered this today and on my end, the issue was fixed by selecting "V1" even if it says "deprecated" at Postman's export page. It seems Postman's v2.1 cannot be processed properly into SoapUI as well. For more details on the steps for fix, you can refer to this page:


"an Engineer without a degree, a QA tester without any official certification (just yet 😉 ) "
Showing results for 
Search instead for 
Did you mean: