Ask a Question

Tag in ReadyApi


Tag in ReadyApi

Can any one please explain how the tags work in readyApi, when you run from commandline, testrunner.bat. I can not use what is written in the documentation

I have testSuites and testCases, some of them taget and some not. Let us say testSuite1 has tag 'regressionTest', testSuite2 has tag 'unitTest' and testSuite3 has tag 'smokeTest'. How should I write on the commandline if I only want to run the testSuite tagged with 'regressionTest'. I have tried 

>testrunner.bat -f"%WORKSPACE%\output1" -FPDF -j "%WORKSPACE%\my_project" -T"TestSuite regressionTest"

but I still get the whole project run. I appreciate your answer.

And what does this mean? 

The specified tags must be assigned to the test cases and test suites that you specify by using the -s and -c arguments. Otherwise, there will be no tests to execute.

Do I need to write every testsuite with -s and every testcase with -c before I can use the Tag? Please any noe can explain?

Super Contributor

If you are unsure of how to create the command line for TestRunner.bat have you tried using the TestRunner GUI to geterate your command line for you? The documentation is here:


The one thing that I spotted was that the documentaion has the project specified after all of the arguments, in your example it is not. Try:


testrunner.bat "-f%WORKSPACE%\output1" -FPDF -j -T"TestSuite regressionTest" "%WORKSPACE%\my_project" 



Note: I have not tested this so I recommend that you use the GUI linked above.

Thanks , I have tried with both 

testrunner.bat "-f%WORKSPACE%\output1" -FPDF -j -T"TestSuite regressionTest" "%WORKSPACE%\my_project" 


"-TTestSuite regressionTest"

None of them works. By that I mean no test is excuted now. The documentation is abit confusing. It says:

Usage: -T"<Test Item> <Tags>", where:

then it says :

"-TTestSuite Tag1 && !Tag2" "-TTestCase Tag3 || Tag4"

That is why I have tried both -T" and "-T ... no test is excuted now.


and by the way I use ReadyApi 2.4

Super Contributor

Yeah, I spotted the inconsistency in the documentation as well, I took it to mean that either was is OK.


Did you try using the TestRunner GUI to generate the command line?

Yes I did, and I still do not get any test excuted. But I also get and exception error I need to look into it in more detail. Thanks 

Hi Radford

Finally it worked by using TestRunner GUI to generate the command line. Then I copied the generated cmdline to the cmdline and it worked with "-TTestCase regressionTest". Thank you very much for the idea 🙂 




Showing results for 
Search instead for 
Did you mean: