Ask a Question

DataSource step: groovy script content can not be changed

Occasional Contributor

DataSource step: groovy script content can not be changed

ReadyAPI 2.7.0

Groovy script content can not be changed after re-opening DataSource step


Steps to reproduce:

1. Create new TestCase
2. Add DatasSource step
3. Choose Groovy option for created DataSource
4. Add any property to be able to launch DataSource step
5. Input simple"EAST")

    code and run step
6. Close DataSource step and open it again
7. Change content of the script from '"EAST")' to '"WEST")' and run step again
8. Check 'Script Log' output


"EAST" word is printed twice which means that content of the script is not changed.
Moreover right-click menu in script area does not work (menu isn't displayed) & 'Edit' tab also does not work in Menu bar

(Also reproduced with ReadyAPI v.3.0.0)

Community Hero

Hi @ihorstep

I'm running v2.8.0 and followed your instructions to reproduce the issue with the updated content of the groovy datasource not being picked up, but each time i incremented the value and rexecuted either the individual step, testcase and testsuite the results in the script log changed as expected...i.e. i couldnt reproduce the issue you noticed.

I should highlight that i have come across similar issues in ReadyAPI! where changes id made to my project e.g. changes to properties or REST parameters etc. were not being reflected when i re-executed the step, test or suite. For example, if i created a REST parm, input the parm name and without moving the cursor/caret/focus to another field within the form i clicked onto a different object in the project navigator and then clicked back onto the original REST request to update the parameters, the parm i added last would not be present.

There were some other exsmples that were alot more frustrating, however I did notice that if i made a the requisite change and then saved the project to persist the changes, the updates were always successfully applied.
Its not perfect, it adds s little more effort, but the changes do het reflected successfully everytime.


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Occasional Contributor

Hi @richie, thanks for reply.


That's strange about v.2.8.0 cuz I'v reproduced same scenario in latest 3.0.0 version, though I hoped that update will fix the issue. 


Unfortunatly the problem is still exist for me. RIght now the only way to avoid it is to not close DataSource step in 'Editor' while writing testcase, though it isn't a good solution. 


Best regards


SmartBear Alumni (Retired)

Hi @ihorstep,

This sounds like an issue. Could you please submit a support case and describe the behavior as minutely as possible? Our R&D team will need to take a look at it. You can submit the case here:

Tanya Yatskovskaya
SmartBear Community and Education Manager

Showing results for 
Search instead for 
Did you mean: