Ask a Question

Cannot Import Composite Project

New Contributor

Cannot Import Composite Project

My company is starting to integrate ReadyAPI into our daily testing operations, and we share our Composite Projects via Atlassian Bitbucket. I previously had everything working with 2.1.0, but on upgrading to 2.2.0 I am no longer able to open a composite project.


Things I have tried:


  • Completely deleting all workspaces and projects, manually pulling the composite project from Bitbucket (using command line interface) and then trying to import project via "Import Composite Project."
    • Error: Invalid project file: C:\Users\{employee number}\.readyapi\{folder name} Please try again.
  • Completely deleting all workspaces and projects, using "Import Project from VCS" and entering all details for an automatic git sync. Project does get saved to my local correctly (confirmed with Windows Explorer). However, project does not open and no errors are displayed.
  • Uninstalling and re-installing ReadyAPI, and trying both of the above. Same results.

OS: Windows 7

ReadyAPI version: 2.2.0


Log files attached.


I found this related thread, but the solution wasn't any action I can take or investigate:


Can someone provide any clarity on why my previously functional composite project can no longer be imported?



New Contributor

I solved my own problem.


Turns out that ReadyAPI had checked out and started trying to use the master branch of our project, when the most recent commits were in the develop branch. I manually (via command line) changed the repo to develop, tried again, and succeeded.

Champion Level 0

Thanks for coming back and sharing how you fixed it!


Click the Accept as Solution button if my answer has helped, and remember to give kudos where appropriate too!

In my case the issue was that somehow the project xml details were duplicated in the "settings" file. I just deleted the duplicate and was able to import the project again

Showing results for 
Search instead for 
Did you mean: