cancel
Showing results for 
Search instead for 
Did you mean: 

Oracle SQL parameters not working with ':'

New Contributor

Oracle SQL parameters not working with ':'

I connected to Oracle Database through JDBC step and trying run below query which reads the data from DataSource

 

Select * from schema.table where col1=Smiley Tongue1

 

Below is the property of p1

Name            Value

p1                 ${DataSource#p1}

 

And I'm getting empty results for the above query

 

But, when I run the query with actual value instead of paramter, I'm getting the results.

 

Select * from schema.table where col1='12345'

 

I tried with ojdbc6.jar and also ojdbc7.jar

 

I have this problem only for Oracle. db2 is working for me.

 

 

Building with the Collaborator API

Help Documenation
The Collaborator API is a JSON-RPC API that lets you integrate with Collaborator 9.0 and above. For more information about how the API works, check out the API description here:


Sample Plugins
For an example of an add-in that uses the API, take a look at the Microsoft Word Add-in for Collaborator:


We list all the great plugins our network has already built on this page on the SmartBear website.

Description