Ask a Question

Requirements and Test Sets Intermittently not Visible


Requirements and Test Sets Intermittently not Visible

Hi everyone. My team and I have been experiencing a strange issue with QAComplete for a couple months and we are not sure why/how to resolve it. It seems like a security/access issue or something with filtering that is affecting both Requirements and Test Sets. For some reason, intermittently the Test Sets and Requirements are no longer visible in the application. It takes some flipping through screens and sometimes logging out/back in to fix it. We haven't found one way to fix this issue yet and we haven't always been able to fix it. One workaround that usually works is to find a test case that you know is linked to a test set and/or requirement you are looking for, then click into it through there. This is obviously not ideal.


I haven't been able to figure this out intuitively through looking at menus, items that are checked, or Releases/Folders that are selected. This really hinders our productivity because we can't run our test sets or link requirements when they aren't showing up and it requires troubleshooting to figure out the problem. Has anyone else been experiencing this? 




Hello Rachel,


Thank you for your post. Rachel, when you have the same permissions as another user, but the file count doesn't match between the users, or you are not seeing the same records as another user or you don't see records at all, this all depends on your personal view and most of the time it is Filter and/or Release related.


For Test Sets and Requirements it most of the time is Release related. I suggest first to always make sure you do not have a temporary filter enabled >>> the listing screen should show "(No Filter)".


Also at the release filter level (left navigation panel) >>> make sure that it shows "(All Releases)" and "(All Types)" and make sure that you are in the correct 'Folder'.


Attached for you I have recorded a video. Please let me know if this resolves the issue, thank you Rachel.


Attachment: Release_Filter.swf


Best Regards,

Thanks Christiane but I already checked this before posting and it does not solve the problem. My filter shows as "(No Filter)" and I'm still not seeing most my requirements (some show up but a very small amount do compared to what is there). 

Hello Rachel,


Thank you for your reply. Please provide me with a screenshot where you say a small amount of your requirements show up, but not all that is there. You can send the screenshot to me directly: Christiane.Gangloff@SmartBear.Com.


Best Regards,

Thanks Christiane. My problem has been solved. The issue turned out to be with filters in multiple tabs of requirements. For example, when I was looking under the Releases tab in the Requirements, I had also selected a folder in the Folders tab. Clicking the parent directory folder allowed all requirements to be displayed.

Showing results for 
Search instead for 
Did you mean: