Ask a Question

AQtime 8.71 does not start C++Builder 10.2 application

Occasional Contributor

AQtime 8.71 does not start C++Builder 10.2 application

I am running the Trial Edition of AQtime 8.71 prior to a decision whether to purchase or not. My app is a 32-bit Windows program built with Embarcadero 10.2 Tokyo. I am running on Windows 10 (v1803), 64-bit.


When I run the Performance Profiler, after various modules are loaded, nothing happens - my program doesa not appear on the screen and so there is nothing to profile.


Windows Task Manager shows my app is running (taking up 16% of CPU) but it is nowhere to be seen.


Has anyone else experience this and have a solution?


Thanks in anticipation.




Occasional Contributor

I posted the other day about a similar problem, but in my company, we share AQTime licenses, and some developers can run from inside AQTime, and others have to attach to the running app they are instrumenting. Since we are supposed to all work eith the same tools and permissions, this is a conundrum. When AQTime fails to run the app from inside, the app appears in task manager, but is not running. The only correlation we have found so far between the working and not working AQTimes is that AQTime seems to work for the developeres who installed it ab out a year ago, and not for the recent installations, even though it is the same version for everybody. One significant thing that happened in between is that our company installed some "privilege management software", but it was installed for everybody and with the same privileges. So currently,we are at a loss to understand the difference.

We just tried with a barebone WIn32 application (the default project in VisualStudio 2015). When AQTime fails to run, it stops loading dlls after ntdll.dll (the first dll loaded after the executable file under scrutiny) . When it runs OK, it loads about 3 dozen dlls after ntdll.dll



> "privilege management software"

I understand that this software is a part of required software and is installed for everyone within the company. But is it an option to setup a virtual machine without this software and check if AQtime works on this VM?


P.S. Have you contacted Support as per thread?


  /Alex [Community Champion]
[Community Champions] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Champions]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Champion] signature is assigned on quarterly basis and is used with permission by SmartBear Software.
Showing results for 
Search instead for 
Did you mean: