Customizable object naming conventions
It would save a lot of time, and go a long way towards readability, if users could establish naming conventions for Test Complete to implement while mapping objects.
Perhaps as an extension of the templates feature where users would be able to set up how certain kinds of objects will be named. A button might be set up to be named via the following conventions: Part1(custom text)= "Tamplated", Part2(object property)= contentText, Part3(object property)= objectType, Part4(incamenting number)= start at 00.
As a result, Test complete would name a save button "TemplatedSaveButton00" and or a nav link might be named "TemplatedAbout_UsLink00" with any spaces replaced by an underscore. Should another object happen to have the same naming properties as another the incramenting number would just incrament to give it a unique name.
This would function similarly to the batch file naming capabilities of adobe bridge.