Forum Discussion

jhanely's avatar
New Contributor
2 years ago

Test Case calling a Test Case with Parameters

I tried searching around for similar questions but didn't have any luck, so forgive me if this has been answered before.


I have a test case with 2 steps. We'll call this TEST-T10. T10's very first step has a parameter that can be set. This is fine and works as expected. The problem is when I create another test case that calls upon TEST-T10 and then call a test case that calls upon that test case, I cannot set the parameter for T10's first step. This is pretty crucial to our how we're using Zephyr Scale, as many of the test cases we plan to create will use calls to test cases with simple parameters. 


Example: TEST-T10 has a parameter that is set in step 1. TEST-T11 calls TEST-T10, and you can set the parameters there. A final test, TEST-T12, calls TEST-T11 and thus I cannot set parameters for TEST-T10.


Is there a setting I missed or a button I'm missing?

4 Replies

  • MisterB's avatar
    Champion Level 3

    It seems to be working for me.  I'm on the Cloud version.  In case you've not seen the Help documentation on that feature's use, it's here: Calling a Test Case with Parameters | Zephyr Scale Server/Data Center Documentation (


    Here's an example of it working for me:


    Setup of Test-T10 to use a default parameter of 12345678:


    Setup of Test-T11 (calling Test-T10), using a different parameter of 11112222 that is set in T-11:

    Test Player view of Test-T10 and Test-T11 with different values.  Note: each time you update the parameter of Test-T10 or T11 you will have to click the option to update the Test Player with the latest version of the test case to see the new values:


    Hope that helps.

  • jhanely's avatar
    New Contributor

    Hi Andrew,


    Thanks for the response!


    I think I didn't explain it well. Everything you've done above I have also done. It's when the test scripts start getting nested even more that I'm running into issues. Basically TEST-T12 calls TEST-T11 which will have TEST-T10 as a step. That's where the breakdown is happening. 


    Sorry for the confusion!

  • MisterB's avatar
    Champion Level 3



    Sorry, I missed that point in your original post.  I run into the same issues that you do.  It seems that the functionality is limited to only 1 layer and you can't go deeper than that.  Probably best you speak to the SmartBear support team for help.  I'd be interested in what they say if you don't mind sharing 🙂


    SmartBear Support



    • TraceyAdrian's avatar
      Frequent Visitor

       I also ran into this same issue. Could the SmarBear Support help here ?