Forum Discussion

Jackoby1991's avatar
New Contributor
9 years ago

SoapUI editor appearing small on high resolution monitor

Hi all,

I have an issue at the moment where the SoapUI interface/editor is appearing really small on my laptop. The whole window appears less that 1/4 of my monitor which means it is extremely difficult to use.

If I maximise the window, it fills the screen, but all the content remains as small as it was before.


Looking at other forums and posts on Stack Overflow, I saw that a couple of people recommended enabling the following settings:


Preferences > UI Settings > Use native look & feel


I have tried this but it didn't make any change within the editor after saving preferences and restarting.

I saw someone else also recommend increasing the font size, but this just caused the text to overlap and become unreadable.


Has anyone else had this issue or does anyone have suggestions on how to resolve this?


Additional Info:

Laptop = Dell XPS 13

Screen resolution = 3200 x 1800

SoapUI version = 5.2.1 (tried both 32-bit and 64-bit)
OS = Windows 10 64-bit

I will attach screenshots showing windowed mode and full screen.



12 Replies

  • raincoder's avatar
    Occasional Visitor

    Is there any sense of a light at the end of the tunnel on this bug? I'm still seeing it (v 5.2.1) and it's cause me to pretty much completely abandon SoapUI for Postman because SoapUI is useless to me with as tiny as the user interface is with this bug.  I've tried a number of different solutions from around the web and all of them break the UI in some completely unuseable way.


    Additional Info:

    Laptop = Macbook Pro running Parallels

    Screen resolution = 3840 x 2400 / 5120 x 2160

    SoapUI version = 5.2.1 (64-bit)
    OS = Windows 10 64-bit

  • I'm experiencing the same issue. It's clearly a bug, since high resolution screens are here to stay and the font scaling doesn't handle this increasingly common case correctly. And there's no option to change the font size.

    • Jackoby1991's avatar
      New Contributor

      Thanks for the response.


      Unfortunately, I think you are right. This looks to be a bug...
      I hope they are looking into fixing this as, like you said, these screen resolutions are very common now and it limits their user base a fair bit.


      FYI - There is a font size setting, but it does not help with our issue:

      Preferences > Editor Settings > Editor Font


      Screenshot attached :)

  • bmlewis's avatar
    Regular Visitor

    I was having problems with this as well. I just adjusted my display settings. Leaving it on high resolution but changing the text scaling on that particular monitor. Now my poor eyes can read it without getting strained.