Forum Discussion

SmartElephant's avatar
New Contributor
2 years ago

Persistant WSDL Import Error message



I recently tried to import a WSDL file and received an error saying that an attribute already exists. After correcting this issue, I try again, but still receive exactly the same error.


Even when I create a whole new project with a completely different WSDL (that doesn't even feature the previous offending attribute) I will still receive exactly the same error message (relating to that attribute) – as if it has become persistent in memory and isn't being cleared.


Any idea as how to fix this/what the cause is?

The only luck I've had is to reinstall SOAPUI every time it occurs, but that isn't exactly a fix...

2 Replies

  • It sounds like the issue might be related to a cache or configuration file that is not being cleared when you uninstall and reinstall SOAPUI.

    One thing you could try is to clear the cache and configuration files manually. These files are usually located in the SOAPUI installation directory or in a user-specific directory. You can try deleting these files or renaming the SOAPUI settings folder and see if that resolves the issue.

    Another possibility is that the issue might be related to the version of SOAPUI you are using. You could try upgrade to the latest version or downgrading to a previous version to see if that makes a difference.

    Finally, it's also possible that the issue might be related to the WSDL file itself. You could try validating the WSDL file using a WSDL validator tool to see if it has any errors or inconsistencies. If the WSDL file is not valid, you might need to fix the errors or contact the service provider to get an updated version of the WSDL file.

    I hope these suggestions help you to resolve the issue you are facing.

    • SmartElephant's avatar
      New Contributor

      I can't seem to find a config/cache - I'll keep searching though.


      The WSDL seem to validate find using an online tool so think, that rules that out


      As to downgrading, I might give that a try


      Thanks for the suggestions 🙂