Forum Discussion

anallagundla's avatar
13 years ago

soapUI settings.xml not being picked up by LoadUI

Hi Ole/SmartBeart support

We have soapui-settings.xml for different environments (like dev , qa ), when we try to load soapui settings file for dev environment in loadui soapui runner, I see that tests are run against qa environment.(I think its pointing to qa because before running loadUI tests I ran the soapui tests pointing to qa). So I believe that loadui is not taking our settings file. I have attached images for better understanding.

Can you you please take a look if this an issue or if u can guide us?

P.S : We are currently blocked on 20 projects on this issue!

- A

1 Reply

  • gperrego's avatar
    New Contributor
    I am seeing the same behavior; did you ever get this figured out?

    In my scenario I have a 3 layered property set up:
    The endpoint url is http://${#TestSuite#HostPort}/sample.asmx
    Inside the TestSuite HostPort = {#Global#DEV}
    Inside the Global Properties DEV =

    Running in SoapUI this works, now I am testing to make sure when I run LoadUI I control those global properties. I pointed the SoapUI runner to a seperate settings.xml file and replaced the "DEV" value with an IP to an environment that will make the test fail. The problem is the test still passes which means it is not grabbing the updated file.

    In my scenario the best case would be a way to override the TestSuite Properties (from my understanding currently we can only override the TestCase Properties). The reason is I don't want to have to specify the end point in every different test case so thats why I'm looking to override the Global Properties; which is what I thought changing the settings.xml file would do?

    Is this a bug? If not what does overriding the setting file do?

    Does anyone have any ideas?