Forum Discussion

kfwilkinson's avatar
Occasional Contributor
7 years ago

SoapUI 5.4.0 has Null Pointer Exception on startup on Mac High Sierra


When I go to start up SoapUI-5.4.0 I get this exception:

15:34:38,372 INFO  [DefaultSoapUICore] initialized soapui-settings from [/Users/kwilkinson/soapui-settings.xml]
15:34:38,383 INFO  [PluginManager] 0 plugins loaded in 0 ms
15:34:38,383 INFO  [DefaultSoapUICore] All plugins loaded
	at java.awt.Window.init(
	at java.awt.Window.<init>(
	at java.awt.Frame.<init>(
	at javax.swing.JFrame.<init>(
	at com.eviware.soapui.SoapUI.startSoapUI(
	at com.eviware.soapui.SoapUI$
	at java.awt.event.InvocationEvent.dispatch(
	at java.awt.EventQueue.dispatchEventImpl(
	at java.awt.EventQueue.access$500(
	at java.awt.EventQueue$
	at java.awt.EventQueue$
	at Method)
	at java.awt.EventQueue.dispatchEvent(
	at java.awt.EventDispatchThread.pumpOneEventForFilters(
	at java.awt.EventDispatchThread.pumpEventsForFilter(
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(
	at java.awt.EventDispatchThread.pumpEvents(
	at java.awt.EventDispatchThread.pumpEvents(

I've tried setting the JAVA_OPTS to uncomment the -Dsoapui.browser.disabled=true, I've tried downloading and reinstalling the application, I've tried downloading the .zip file and launching it from the "" file in the .zip file.  None of these work.

I've tried it with JRE 9.0.1 and JRE 1.8.0_161

I'm on Mac, OS X 10.13.3.