Forum Discussion

skymoon's avatar
10 years ago

SoapUI-5.0.0.dmg (2014-04-09) Freeze/Slow Issue.


I'm a mac book user with 10.9.4 OS X.

I've experienced a freezing issue from the SoapUI free mac version (SoapUI-5.0.0.dmg (2014-04-09) 121.2 MB). When I try to click any menu or folder in the user interface, it freezes at least one minute. FYI, I have no problem with the free Windows version of SoapUI 5.0.0.

I've tried most of the suggestions mentioned in the previous posts (adding <con:setting id="UISettings@disable-browser">true</con:setting> to the ~/soapui-settings.xml, change xmx in /Applications/, etc.), but none worked for my case.
There was no log in the soapui-errors.log file in the /Applications/ folder. Accordingly, I have no idea about this bug.

Interestingly, there was no problem with SoapUI Pro trial version and 4.6.4 free version for the mac.

I think it is a bug of the mac version of SoapUI 5.0.0 free.

Any idea or comment?

4 Replies

  • alfanuzeta's avatar
    New Contributor
    I had the same problem!

    I resolved in this way:

    In finder goto to applications and choose SoapUI icon.

    Choose "Show Package Content" option

    In the directory /applications/SoapUI/Contents/PlugIns delete the "jre.bundle"

    After that restart SoapUI and there is no more problem

    The reason seams to me that it runs this java machine instead the default system installed.

    Hope it helped!!
  • alfanuzeta's avatar
    New Contributor
    I had the same problem with this version.

    I have overpass this Freeze/Slow Issue by deleting "jre.bundle" file inside the SoapUI application package content (optio: "Show package content"). You can find this file under the directory "Contents/PlugIns".

    After I doing that all issues regarding Freeze/Slow disappeared.

    I believe that the problem might be with this particular Java engine that comes bundle with SoapUI. When deleted it uses the default installed in your OSX, usually the last Oracle Java machine.

    Hope it helped.
  • Thanks! A combination of disabling the browser and deleting jre.bundle worked for me.