Forum Discussion

mlipanje's avatar
New Contributor
3 years ago

Script Library in Project properties doesn't load

I set my script library in project properties. It works fine when ran from ReadyApi app, but not when ran from TestRunner.


The property doesn't seem to be loaded when ran from testrunner as only global property gets loaded but unfortunatelly I cannot use it in my case.


I am setting my library property with a relative path ("${workspaceDir}\readyapi-utils\common"). The ${workspaceDir} is not resolved in global property but it is resolved in project property...


Any idea on how to load project sctript libs ?


Thanks for your help.






1 Reply

  • mlipanje's avatar
    New Contributor


    I managed to pass it to CLI via "-Dsoapui.scripting.library=fulPathToWorkspace\readyapi-utils\common", where I can manipulate the full path.