Forum Discussion

AdamDavisNant's avatar
Occasional Contributor
9 years ago

Run Test Case as test step failure

I have a REST test case that makes an authentication call. I use it to authenticate for all other REST test cases in the project. It was working in 1.4.1 and it worked fine. When we upgraded to 1.5 it started to fail. When we use the "Run Test Case as Test Step" the authenitcation test case is getting messed up. It longer has the REST icon next to it and we can not call it or get any data to the calling test case. Any one less seeing this kind-of behavior?


 We have tried rebuilding the authenitcation test step and have tried recreating the test cases all to no avail. Did something change with the Run Test Case as Test Step?

15 Replies

  • TanyaYatskovska's avatar
    SmartBear Alumni (Retired)

    Hi AdamDavisNant,


    I would appreciate if you recorded a video demonstrating this issue so that our Developers Team could watch it. You can use a free video recorder – Jing.

      • tomaszarmata's avatar

        I have exactly the same problem.


        I run my "TestStep1" in "TestCase1" which runs "TestCase2" through "Run TestCase" test step type. It finish with success. But when after this I try to run first step of TestCase1 which is a groovy test step it gives me message: "java.lang.NullPointerException".