Forum Discussion

minhng's avatar
minhng
Occasional Contributor
3 years ago
Solved

ReadyAPI hangs when running different test cases against different environments in sequence

Hi,

I have set up multiple environment configurations in ReadyAPI (Dev, Test and Stage) - each of them include actual endpoints and project properties.

It works well when I execute a test case switching between those envrionments in sequence. As soon as I subsequently try to execute another testcase then ReadyAPI hangs and it has to be aborted with Windows Task Manager ğŸ˜ž

 

Anyone has experienced the same? Appreciate to receive some advices. 

  • Hey minhng,

    So just to be clear....so we understand what's happening.

    You have a project and multiple "environments" setup.
    You launch ReadyAPI which defaults to an environment.
    You execute some tests
    Then you switch environments
    You then try and execute tests (the same tests or different tests in the same project?) against a different environment and this is where it hangs?

    What ReadyAPI version are you running?
    Does it always hang when trying to execute different tests within your project after switching environments?
    What's the RAM/CPU usage after you switch environments?
    Is the ReadyAPI project youre executing large?
    Have you monitored the ReadyAPI and Error Logs to see if anything is reporter as an error/issue?

    Cheers,

    Rich
  • Hi Rich

    Thanks for the reply.

    The problem is gone after I have changed to another more powerful (CPU/RAM) computer. It seems like ReadyAPI turns out to be more resource demanding when running with multiple configured environments. Yes. we have large test cases. But we have not experienced such issue when excuting towards single environment.

    I close the case. 

    Cheers.

    -Minh

2 Replies

  • richie's avatar
    richie
    Community Hero
    Hey minhng,

    So just to be clear....so we understand what's happening.

    You have a project and multiple "environments" setup.
    You launch ReadyAPI which defaults to an environment.
    You execute some tests
    Then you switch environments
    You then try and execute tests (the same tests or different tests in the same project?) against a different environment and this is where it hangs?

    What ReadyAPI version are you running?
    Does it always hang when trying to execute different tests within your project after switching environments?
    What's the RAM/CPU usage after you switch environments?
    Is the ReadyAPI project youre executing large?
    Have you monitored the ReadyAPI and Error Logs to see if anything is reporter as an error/issue?

    Cheers,

    Rich
  • minhng's avatar
    minhng
    Occasional Contributor

    Hi Rich

    Thanks for the reply.

    The problem is gone after I have changed to another more powerful (CPU/RAM) computer. It seems like ReadyAPI turns out to be more resource demanding when running with multiple configured environments. Yes. we have large test cases. But we have not experienced such issue when excuting towards single environment.

    I close the case. 

    Cheers.

    -Minh