Forum Discussion

dpasotti's avatar
Occasional Contributor
8 years ago

Property expansions failing in Maven, but working in UI

I have 2 JDBC steps that contain assertions with a property expansion. The properties are expanded correctly in the GUI, but when I run the project on the Maven plugin, they evaluate to '[]'. I.e. they are not being expanded, and as a result my build fails. I have at least 1,000 property expansions all over my project referencing properties at all levels (Project, Suite, Case...), but these are the only 2 that are failing, and I have no idea why. I've tried changing the property locations from Test Case to Test Suite, tried changing the assertion from XPath to Message Content, and I cannot figure out why this is happening for just these 2.


This is not the first time I've had a situation like this, where something runs correctly in the UI, but fails in Maven for reasons unknown. Anyone experienced this issue and know how to resolve it?


Thanks, David

No RepliesBe the first to reply