Forum Discussion

Junglos's avatar
New Contributor
6 years ago

Problem running virtual service from exported war file on tomcat

Hi Everybody,


I'm currently trying to test virtual services (created from wsdl file) that are exported to a *.war file and deployed in tomcat. The deployment is successful, it is visible and runing when you check in "Manager App". The problem starts when I want to enter the link and view the WebUI. Everytime I get a 500 Error "com.eviware.soapui.DefaultSoapUICore cannot be cast to com.eviware.soapui.mockaswar.MockAsWarCoreInterface". 


Error from browser: 

java.lang.ClassCastException: com.eviware.soapui.DefaultSoapUICore cannot be cast to com.eviware.soapui.mockaswar.MockAsWarCoreInterface

Server logs:

04-Sep-2018 13:57:56.226 SEVERE [http-nio-8080-exec-3] com.eviware.soapui.mockaswar.MockAsWarServlet.init null
	at com.eviware.soapui.impl.wsdl.mock.WsdlMockRunner.start(
	at com.eviware.soapui.impl.wsdl.mock.WsdlMockRunner.<init>(
	at com.eviware.soapui.impl.wsdl.mock.WsdlMockService.start(
	at com.eviware.soapui.mockaswar.MockAsWarServlet.init(
	at javax.servlet.GenericServlet.init(
	at org.apache.catalina.core.StandardWrapper.initServlet(
	at org.apache.catalina.core.StandardWrapper.loadServlet(
	at org.apache.catalina.core.StandardWrapper.allocate(
	at org.apache.catalina.core.StandardWrapperValve.invoke(
	at org.apache.catalina.core.StandardContextValve.invoke(
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
	at org.apache.catalina.core.StandardHostValve.invoke(
	at org.apache.catalina.valves.ErrorReportValve.invoke(
	at org.apache.catalina.valves.AbstractAccessLogValve.invoke(
	at org.apache.catalina.core.StandardEngineValve.invoke(
	at org.apache.catalina.connector.CoyoteAdapter.service(
	at org.apache.coyote.http11.Http11Processor.service(
	at org.apache.coyote.AbstractProcessorLight.process(
	at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(
	at java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.util.concurrent.ThreadPoolExecutor$
	at org.apache.tomcat.util.threads.TaskThread$

I read some posts on the internet about this but they are minimum 1-2yrs old and no solution worked for me. I tried exporting the war file from two versions of ReadyApi 2.3 and 2.4, ran it on two systems windows and ubuntu and on two versions of tomcat version 8 and 9. I also tried making everything from scrach (without using a wsdl file) and also no luck.. always get that error. Can somebody help me? Anybody had this issue?





2 Replies

  • Junglos's avatar
    New Contributor

    Additional info:

    This time I generated the war file in SoapUI 5.3.0 free version and it worked. Got it deployed in tomcat without problems and its running. Now the question is why can't I get it running when I save the war file in ReadyApi ??