Forum Discussion

TonyBray's avatar
New Contributor
6 years ago

"Log is disabled" returned when mockservice war is deployed on Tomcat

Hello everyone!

I have been using SoapUI Pro for a little bit and thank you all who have posted before, I have gotten so much help from this board already.   However, I have an issue that I can't find a solution to on here.


I have created one Rest Mockservice already, deployed it to a remote Tomcat server and it works well.  I created a second mockservice and deployed it.  However, when I hit it with a request, it returns the following xml:

<title>SoapUI MockServices Log for project [PaymentOS-soapui-project]</title>
<h3>Log is disabled.</h3>


The first mock still works fine.  I build the war via a Jenkinsfile using a docker container with SoapUI 5.4.0 installed with the following command: -f mywarname.war -d path/to/my/soapuiproject.xml

The jenkinsfile and docker image are the same for both projects except for the war name and soapui project name.

I copied the war file from my nexus repo to my local machine and push it into a tomcat docker container and it gives the same error.  This rules out collusion with the first mockservice war already deployed on my remote server.


I have double-checked my project settings between the two mock services and other than my mock specific logic, I don't see a difference.  I can post the project.xml if it would help any.  Thank you in advance for any assistance provided!

2 Replies

  • TonyBray's avatar
    New Contributor

    Found it!  Was building the war in a jenkinsfile that used a docker container.  I gave it the project name  but since I copied it from the file, it didn't include the extension.  Interesting thing is that the wargenerator built a war.  Of course once deployed it couldn't reference the xml properly and caused the error.  Hopefully this might save someone else a lot of frustration in the future.

    • Olga_T's avatar
      SmartBear Alumni (Retired)

      Hi TonyBray,


      Many thanks for sharing your solution with the Community! It is sincerely appreciated :smileyhappy:

      Could you please click the Accept as Solution button below the post where you provided the solution? This makes the search for the answer easier for users in the future if they face a similar issue.


      Thank you in advance!