Forum Discussion

krogold's avatar
Regular Contributor
7 years ago

How to use assertion steps without getting stuck ?


I'm quite new to SoapUI. I'm developping test suites and, in order to test a variable against a few values, I tried to insert an Assertion test step.

I did it just after my request and referred to it. It did work actually, but no it doesn't any longer and I can't figure out what I've changed.

The fact is that, when I play my test case (or my entire collection), I get stuck at this test step, without any information. 

Moreover, if I want to see into it, I cannot select it !

In order to be able to open it I have to close/open Ready API.

Then, I can sometimes run the test successfully ...

Have anybody run through such a problem ?


thanks for any help


4 Replies

  • Nastya_Khovrina's avatar
    SmartBear Alumni (Retired)

    Hi krogold,


    Thank you for your post! What errors do you have in Logs?

    1. In Ready! API, open the Logs panel by clicking "Logs" in the bottom left corner.
    2. Clear the following logs (right-click within the log panel and select the "Clear" context menu item):
    - Ready! API log
    - Error log
    3. Reproduce the problem.

    • krogold's avatar
      Regular Contributor


      Thank you for your reply, but I cannot reproduce it, it happened two or three times without particular combination of sequence. As soon as it will appear again, I'll post the log



    • krogold's avatar
      Regular Contributor


      I'm back again on this problem :

      I launched several times my testcase without problem, I could access the Assertion step.


      Then I did add a groovy step in my testCase

      I realized that it was finally useless and I deleted it (I thought I did but, in fact, it didn't work)

      I duplicated a test step that I moved above my unwanted groovy script.


      Now that I have this groovy step that I cannot delete, when I run my testCase it fails on my assertion step.

      I can no longer open this assertion step.

      I cannot delete my groovy script


      please find attached all the available logs (unfortunately, if I clear logs before launching my test case, no error appears ? so I attach a full log)


      thank you