Forum Discussion

678's avatar
678
Regular Contributor
5 years ago

Failed to Generate Reports

When ever i treid to generate customized report getting below error 

 

Failed to generate a report. Make sure the property "Custom report library" is set to the folder where the report templates are stored (by default, /bin/reports).

 

Even though i tried allmost all the possible solutions provided in the community 

 

 

4 Replies

  • TanyaYatskovska's avatar
    TanyaYatskovska
    SmartBear Alumni (Retired)

    Hi 678,

     

    Have you tried specifying the full path to the folder, like C:\Program Files\SmartBear\ReadyAPI-2.6.0\bin\reports ?

    Try doing this and restart ReadyAPI. If you see the same issue, I suggest that you contact our Support Team to investigate the behavior. You can get in touch with them here: https://support.smartbear.com/message/?prod=ReadyAPI

    • 678's avatar
      678
      Regular Contributor

      Tried full path 

      i can able to get report if i user Junit,Project printable or CSV which is pr-configured reports templates 

      where as if i create a custom report (TestSuites reports) than getting failed to generate reports error 

      • jasond's avatar
        jasond
        Occasional Contributor

        Ditto.

        It will generate a few times, then fail. restart & Itll work again.

         

        Thu Nov 28 16:34:40 EST 2019: ERROR: An error occurred [Failed to generate a report. Make sure the property "Custom report library" is set to the folder where the report templates are stored (by default, <ReadyAPI installation folder>/bin/reports).], see error log for details