Forum Discussion

zoe's avatar
zoe
New Contributor
10 months ago
Solved

Error Code: 502 Proxy Error in ReadyAPI

ReadyAPI is not working properly. I want to test an API using ReadyAPI for the first time. I created a simple test case. When I run it I get the following response.

<HTML><HEAD><TITLE>Error Message</TITLE>
<META http-equiv=Content-Type content="text/html; charset=utf-8">
<BODY>
<TABLE><TR><TD id=L_dt_1><B>Network Access Message: The page cannot be displayed<B></TR></TABLE>
<TABLE><TR><TD height=15></TD></TR></TABLE>
<TABLE>
<TR><TD id=L_dt_2>Technical Information (for Support personnel)
<UL>
<LI id=L_dt_3>Error Code: 502 Proxy Error. The specified Secure Sockets Layer (SSL) port is not allowed. Forefront TMG is not configured to allow SSL requests from this port. Most Web browsers use port 443 for SSL requests. (12204)
<LI id=L_dt_4>IP Address: 192.168.X.X
<LI id=L_dt_5>Date: 5/13/2023 6:38:14 AM [GMT]
<LI id=L_dt_6>Server: myCompanyServer
<LI id=L_dt_7>Source: proxy
</UL></TD></TR></TABLE></BODY></HTML>


Also, in the assertion pane I get this message:
readyapi open quote is expected for attribute http-equiv associated with an element type meta


I tried adding this line at the end of `ReadyAPI.vmoptions` file:
-Dsoapui.https.protocols=TLSv1,TLSv1.1,TLSv1.2
But I'm still getting the same error.

How can I fix it?

  • It was due to the proxy settings. By default, it was set to automatic. So, it used the proxy settings of the company. I set it to "none". Now, it's working properly.

1 Reply

  • zoe's avatar
    zoe
    New Contributor

    It was due to the proxy settings. By default, it was set to automatic. So, it used the proxy settings of the company. I set it to "none". Now, it's working properly.