Forum Discussion

Pravin01's avatar
New Contributor
6 years ago

Data Sink - "java.lang.Exception: Failed to prepare the step [DataSink]" when run through Jenkins


I am using file path from groovy script instead of hardcoding it in data sink output folder, since I have multiple environment and I can not hard code output file to avoid overwriting same file again and again.


It works fine when I ran locally. But it fails when I run through Jenkins. Please see attached screen shot for my test and jenkins error.


I am using ReadyAPI2.3.0. All other projects where sink data file is hard coded working from thorugh Jenkins.


Please advise.


Thank You.


5 Replies

  • Pravin01's avatar
    New Contributor

    Error occurs even when I run Test in Ready API. Its clearly data sink step issue.

    I am just feeding grovvy script result (which return file path based on env. selected) to data sink instead of hardcoded file path. When I debug groovy script step PASS but data sink fails.

    Please see attached three screen shots to get clear idea of what I did and the error I am getting.


    Appreciate any help to resolve this issue.

    Thanks in advance.