Forum Discussion

666666's avatar
Occasional Contributor
10 years ago

Cannot open Editor for test steps for v. 4.6.2+

Hello, I have raised a bug on SoapUI's project at SourceForge but looking at the activity there I am not sure what is the correct place to file a bug, so I will copy it to the forum as well. If I am wrong, then please accept my apologies and have the thread closed.

We are currently writing test cases to test a web service using Windows 7 64bit and v. 5.0.0 of SoapUI. We have tried using both the standard and Pro version (Trial).

The problem is that we are able to open the editor for each test step for our older SoapUI projects, however, it is not possible with the newly written project. We attempted to have it opened with an older version of the SoapUI program and tried most of the major versions until we found out the editor can be opened successfully on versions prior to 4.6.2. Thus, version 4.6.1 is the newest version where the test steps may be opened in the editor.

In the error log, located at bin/soapui-errors.log, a Java exception is logged - java.lang.IndexOutOfBoundsException.

Complete stack trace is:

2014-07-03 11:32:06,042 ERROR [errorlog] java.lang.IndexOutOfBoundsException: Index: 14, Size: 14
java.lang.IndexOutOfBoundsException: Index: 14, Size: 14
at java.util.ArrayList.rangeCheck(Unknown Source)
at java.util.ArrayList.get(Unknown Source)
at com.eviware.soapui.impl.wsdl.panels.teststeps.RestTestRequestDesktopPanel.updateFullPathLabel(
at com.eviware.soapui.impl.wsdl.panels.teststeps.RestTestRequestDesktopPanel.addBottomToolbar(
at com.eviware.soapui.impl.wsdl.panels.teststeps.RestTestRequestDesktopPanel.(
at com.eviware.soapui.impl.wsdl.panels.teststeps.RestTestRequestPanelBuilder.buildDesktopPanel(
at com.eviware.soapui.impl.wsdl.panels.teststeps.RestTestRequestPanelBuilder.buildDesktopPanel(
at com.eviware.soapui.ui.desktop.standalone.StandaloneDesktop.showDesktopPanel(
at com.eviware.soapui.ui.Navigator$TreeMouseListener$
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$200(Unknown Source)
at java.awt.EventQueue$ Source)
at java.awt.EventQueue$ Source)
at Method)
at$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at Source)

I am attaching a project file that will reproduce this behavior.

I will provide additional details on request.

Thank you.

5 Replies

  • Hi,

    Interesting, I have reproduced the same issue using your project. I will raise this to the development team for them to look at further.
    • 50ReggieTest's avatar
      Occasional Contributor



      Any updates?

      This always happens to me, everyday. And I have no choice but to restart the app. I would be a great to have this fixed.


      SoapUI NG Pro - ReadyAPI 1.7.0 on Windows 7 Enterprise (64bit)

      - with 8 GB of RAM




      • jdario's avatar
        Occasional Contributor

        It's 3 years later and I'm using ReadyAPI! v2.5.0 and I'm having the same problem. Wish we could have a custom solution so that we don't have to wait on third party developers.

  • Anonymous's avatar
    There are resource parameters with empty names which are causing the problem. Fix for this will be available in next release soon.
    The workaround is to open it in 4.6.1 and delete the parameters with empty names in Resource Editor (WebApi X[/example] , save it and then you should be able to open it in later versions.

    Best Regards,