Forum Discussion

richie's avatar
Community Hero
4 years ago

Cannot Import .wsdl with Imported Schemas (.wsdl found to be invalid)



Can't believe I've never stumbled across this before - but I'm trying to import a .wsdl with namespace/schema references that are imported rather than the alternative option of inlining the schema references instead.


However - the import of the .wsdl is failing and I believe it's because the schema is being imported resulting in the .wsdl file not being schema valid (cos certain elements reference the imported namespace - the elements cannot be found).


I haven't got a copy of the imported schema so cant convert to 'inline'.


I've tried remapping the offending elements to a different namespace but that didn't work.


I knew that trying to import a malformed xml file (beit .xsd, .xml, .wsdl or whatever) would result in the file not being loaded in successfully - but Id never actually tried importing a file that is found as schema invalid.


I now know readyapi! needs the .wsdl to be schema valid as well as wellformed - but I was wondering if anyone had a work around that didn't include obtaining the offending schema (new job - it could be weeks before I have access to the relevant schema)???