Forum Discussion

pshmell's avatar
New Contributor
10 years ago

[LoadUIWeb] Content-Length errors in POST requests


I am using LoadUIWeb to test a web application built with Enyo (an html5/JS app engine) and am getting warning messages when I run my scenarios.

All of my GET requests are OK but the POST requests all give me warning with 400 Bad Request errors. The only discrepancy between the Recorded Value and the Simulated Value in my Request Headers is that the Content-Length is ~30 bytes longer in the test runs than in my recording.

All Request Headers are affected in the same way, varying from 30-36 bytes longer.

Attached is a screenshot of the message log.



1 Reply

  • pshmell's avatar
    New Contributor
    OK I found out more about the problem but still no solution.

    In the Text tab of the Request tab (see here) you can see/edit the body of your request. My request is of the multipart/form-data type.

    It seems that LoadUIWeb prepends and appends the text '--t/form-data' to anything you enter in the text field.

    However, the RESTwebsvc that handles my requests does not want this. It wants the raw stream of UTF bytes. Is there any way to have LoadUIWeb not add the --t/form-data string?