Forum Discussion

lstauffer's avatar
Occasional Visitor
2 years ago

Uploading test results creates a duplicate test

I've created a Test Automation task, where I want to upload test results to 2 tests I've already created in Zephyr Squad.


In the XML I created, I test the 2 test cases, using the "name" attribute set to the names of my test cases I created.  One test I'm setting a failure, the other test I'm not setting anything, expecting the result to be a pass.

- Test case "Automation_Example_Test_1" I've set the failure.

- Test case "Automation_Example_Test_2" I haven't set any failure.


For some reason when I execute the Test Automation task, the correct results are being set to the test cases, however an extra test case named "Automation_Example_Test_1" is created.  This new test case shows the failure.  But my original "Automation_Example_Test_1" shows "unexecuted" status.


I've tried to use IDs, I've tried playing around with the attributes, I've checked the spelling, but an extra "Automation_Example_Test_1" is always created.


Any ideas as to why?  (I've attached the XML I'm using)

No RepliesBe the first to reply