Forum Discussion

9 Replies

  • Hi,


    Unfortunately, you cannot modify the environment for your executions when using our automation endpoints.



  • Hi! 

    I am a bit confused about the way you are making this request. It looks like you show us a screenshot of a web browser in which you have used the URL to upload results. Do I understand it correctly?

    • serra94's avatar
      New Contributor

      Hi David !!!

      Thanks for the answer !!!

      I will try to explain the steps I took below.

      1- I inserted the test key inside the test case name that is in the robotframework:




      2 - Later I run the test using the parameter "-x" to generate the xml file:




      3 - I generated an access token




      4 - Creating the requisition



      * Response  in terminal*




      Response using Insomnia *





      I've tried following the steps in this example, but as you can see it doesn't work.




      I'm newbie forgive me if there is any stupid mistake !!!


      Anyone who can help with guidelines I'm very grateful!!!


      • DavidL's avatar

        In Insomnia, can you try to add a Query parameter which would be named autoCreateTestCases. The value needs to be set to true. That should solve your issue and you can see the results in Scale. 

        You mentioned you added test case keys to your robot tests. Do you have a test case key for each of your tests or some of your tests do not have a corresponding test case key?


        If you want to use the curl command, you probably need to escape some characters in the URL. 


        or you could try to use the URL like this (between double quotes)


  • arf1996's avatar
    New Contributor

    Hi DavidL, I have an additional question regarding your comment:


    DavidL : "...or you could try to use the URL like this (between double quotes) '' "


    Question: I wanted to edit the environment of my test execution and can't seem to make it work. This is what I was trying out ""



    • grarun11's avatar
      Occasional Contributor

      Hi DavidL 

      Personal access token different from zephyr scale API access token?

      I do see only Personal access token in my profile.