Forum Discussion

think-about-it's avatar
New Contributor
7 years ago

oauth2 GET request fails with HTTP 500 unable to verify the first certificate

I've got a swaggerhub API with a request that has OAUTH2 authentication.

When I "Try it out" and enter a token into the Authorisation field and Execute the request I get an HTTP 500 error: "unable to verify the first certificate".


When I run the displayed "curl" command in a terminal window it works.


Any suggestions?

2 Replies

  • Hi,


    Please give us the URL of your spec in Swaggerhub so we can try to reproduce the issue.  If your API is private then you please make swaggerhub-support a collaborator.  You can send me a private message if you do not want to share the spec link on the forum.




    SmartBear Support

    • think-about-it's avatar
      New Contributor

      Thanks for the reply.

      Looks like its an issue with my API server not returning the intermediate certificate correctly.


      Tried the curl command again and I also get an error with that. I must have added in the -k option whilst trying to trace the error.