Forum Discussion

xerces8's avatar
Occasional Contributor
7 years ago

wsdl refreshed

In soapUI 5.3.0 it happened that the WSDL was refreshed to some older version, and the tests failed in the "Schema Compliance" condition.


I fixed it by using the "Update Definition F5"  menu to reload the correct WSDL (from the same URL, which was correct all the time).


Why did soapUI change the WSDL definition, without being asked to?

Is it some bug?


In the Interface dialog on the "WSDL Content" tab I can confirm, thet the wrong WSDL was shoen and after updating it was correct again.


I restarted soapUI now and it happened again. A wrong version of the WSDL appeared again in this project.

This worked fine for several days, until today 1 hour ago.

I'm not sure, but it seems when I exit and start soapUI again, the bad WSDL appears.


Any idea why this is happening? As said, it worked fine for days before that (with exiting and starting soapUI several times).




1 Reply

  • xerces8's avatar
    Occasional Contributor

    Another funny thing:

    I noticed in another project that its WSDL was also changed to a newer version, without me triggering that.

    Luckily I had backups of the soapUI project files and could easily revert.