Forum Discussion

johnrix's avatar
Occasional Contributor
11 years ago

SSL Support for REST MockServices in 5.0.0

I'm trying to mock a REST callback in SoapUI 5.0 beta to support an asynchronous callback from my system under test. The callback URL is required to be a secure address. I have configured my SSL settings and enabled SSL for Mock Services.

However, it seems the SSL support for mock services is still very much geared to SOAP services using fixed endpoint paths. I can get a valid response from the REST MockService on the SSL port ONLY if the request path I send to the SSL port matches exactly the Path configured in the MockService Options page AND the same path is used as the Resource Path in the MockAction editor (which by itself seems somewhat counter-intuitive). If I append anything further to the path, I get the bog standard HTML response about current number of running SoapUI MockServices.

This effectively means that:

* I would have to create separate REST MockServices for each REST resource I wanted to address
* I can't use parameterised paths at all (unless I limit myself to a specific set of parameter values and create individual MockServices for each!)

Am I missing something obvious?

8 Replies

  • GiscardN's avatar
    Frequent Contributor

    Currently, there should not be anything added after the "/" in the path for a REST MockService. We are addressing that configuration detail in the MockService Options that has come to our attention. As the REST MockService is generated from a REST Request, the path will map to its resource.
    We appreciate your feedback.


    SmartBear Support
  • johnrix's avatar
    Occasional Contributor
    Thanks Giscard. I'm not sure I fully understand what you are saying though. Do I understand correctly that you are looking to improve on the current behaviour (perhaps as part of the 5.0 GA release)?

    If I use only "/" for the REST MockService Path, I cannot use it over the SSL connection at present, since my real resource paths will not be matched by the listener on the secure port. (It works fine on the non-secure port though.)

  • Hi John,

    Have you found a solution for this problem? I'm facing the same issue...

    I've tried several things like creating mock Actions with the full url so the Resouce Path is something like "https://localhost:8443/...", but no luck