Forum Discussion

jkrolczy's avatar
Regular Contributor
7 years ago

SoapUI OS 5.4.0: Setting Project level Custom variable issue from groovy script

I am seeing a weird issue which I cannot figure out.


I have a test script where I run it and from the response is a very long tokenID.

I dump it to a text file (for use by other projects within workspace in the future)


I have a groovy script where:

I read the file (tokenID) value and set a Project level custom variable,


I have another groovy script to just read the Project level custom variable

to the Project variable to show that the tokenID value is there.


When I run the complete test scripts what all the steps, all works great.


Once the script finishes, if I go manually to the Project level to view the

Project level custom variable, it is blank even though all the groovy scripts

executed correctly.


If I manually run the groovy script where I read the file (tokenID) value

and set a Project level custom variable and viewing the Project level custom variable

it does get set and I can see it.


Don't understand while executing the script(s), the tokenID exists for script use

but the Project level variable is never set even though the code should be setting it.


I thought maybe the length is an issue ???

It is a very long tokenID string of number an letters.

But manually running the groovy script will set the variable.


I can work with the behavior if the value is there for all the scripts to use until execution completes.

Just wish I could see the variable actually set from test scripts(s) execution.


Anyone seen this before or is this a 5.4.0 issue ?






No RepliesBe the first to reply