Forum Discussion

algy's avatar
New Member
4 years ago

SoapUI: Connection refused when accessing mock SOAP API

Hi all,


I've got a working WDSL file, and going to http://localhost:8088/myservicename?WDSL displays that WDSL file.  All is working fine up to that point.


However, if I write a simple python script like this, which should display the list of available methods


    from suds.client import Client
    client = Client('http://localhost:8088/myservicename?WDSL')


I get a "Connection refused" error.  The same happens if I try to call a specific function specified in the WDSL file, or if I type `wget http://localhost:8088/myservicename?WDSL` at the command line.


To me, the obvious answer was that for some reason I couldn't connect to that port.  I tried adding a rule to Windows Defender Firewall to permit any traffic to port 8088, but still experienced the same problem.  I also tried turning off the proxy in SoapUI, but again still get the same "connection refused" error.


I'm sure this is a very basic, n00b question but I've exhausted all the help I could find in the documentation and on StackOverflow!


[nb: I've used the same address as it mentions in the soap:address element in the WDSL response.  I did think it was maybe that I was using the wrong address, but that's not it either!]


All the best


1 Reply

  • richie's avatar
    Community Hero
    Hey algy,

    Connection refused sounds like authentication/authorisation.

    Have you looked into if theres any auth details you need to include in your requests?