Forum Discussion

PG's avatar
PG
Occasional Contributor
4 years ago

Soap TestSuite runs with different configurations - ReadyApi

Hello,

 

I use Ready Api 3.6.0 version on 2 PC.

 

First PC configuration:

 - AMD Ryzen 5 PRO 3500U w/ Radeon Vega Mobile Gfx 2.10 GHz
 - 8 GB RAM
 - Windows 10 Enterprise 64 Bit

 

Second PC configuration:

 - Intel(R) Core(TM) i7-6700 CPU 3,40GHz 3,41 GHz
 - 16 GB RAM
 - Windows 10 Enterprise 64 Bit

 

I run the same TestSuite, which contains 6 TestCase and 30.000 cases run in one run:

 - DataSource (with DB conntection)
 - Soap Request (with 41 input paramteter)
 - Property Transfer
 - DataGen
 - DataSink (with DB conntection)
 - DataSource Loop

 

Based on configurations, the TestSuite should run faster on the 2nd machine, but the results are almost the same.

 

Is there any configuration settings in ReadyApi about the RAM?

My ReadyApi.vmoptions file contains the following lines:

-XX:MinHeapFreeRatio=20
-XX:MaxHeapFreeRatio=40
-Xms128m
-Xmx8192m

 

Thank you!

 

  • Hi,

    I take the API is not hosted on 1st or 2nd?  If not, then the test is still most likely as fast as it's slowest part.

     

    The harness may run slightly quicker on the good PC, but if 1st and 2nd PC are both calling an API on some other machine, then that would explain little difference.  Most of the time will be spent calling and awaiting a response form the API.

6 Replies

  • PG's avatar
    PG
    Occasional Contributor

    Hello,

    Is there anyone who can help about this topic?

     

    Thank you!

     

    Regards

    Gábor

     

      • PG's avatar
        PG
        Occasional Contributor

        I'm using the latest Ready API 3.6.0 version.