Forum Discussion

jrahman's avatar
9 years ago

SLF4J: and java.lang.ClassNotFoundException: errors found on SoapUI-x32-5.2.1

Hello All:

I am getting SLF4J and ClassNotFoundException errors while running test using testrunner.bat of SoapUI 5.2.1 (x-32 version). Could you please let me know where is the problem ?



OS information:

Windows 7 Enterprise


The error logs are as below:

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.
at$ Source)
at$ Source)
at Method)
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.eviware.soapui.plugins.LoaderBase.loadAutoFactories(
at com.eviware.soapui.plugins.LoaderBase.loadFactories(
at com.eviware.soapui.plugins.PluginLoader.loadPluginFactories(
at com.eviware.soapui.plugins.PluginLoader.loadPlugin(
at com.eviware.soapui.plugins.PluginLoader.loadPlugin(
at com.eviware.soapui.plugins.PluginManager.doInstallPlugin(
at com.eviware.soapui.plugins.PluginManager.access$600(
at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.computeSequentially(
at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(
at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(
at java.util.concurrent.RecursiveTask.exec(Unknown Source)
at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
at java.util.concurrent.ForkJoinWorkerThread.execTask(Unknown Source)
at java.util.concurrent.ForkJoinPool.scan(Unknown Source)
at Source)
at Source)

  • Finally, the problem was solved !


    The other problem ties to the default plugins installed under "C:\Users\<user name>.soapuios\plugin".


    For SoapUI 5.2.1, there are 4 default plugins installed under this directory:

    1. readyapi-swaggerhub-plugin-1.0.jar
    2. ready-mqtt-plugin-dist.jar
    3. ready-uxm-plugin-1.0.1-dist.jar
    4. soapui-swagger-plugin-2.2-dist.jar

    Renamed the original folder 'plugins' to 'plugins_NOTinUse' (or something else), so that default plugins could be forced hidden during runtime. The problem then disappeared.


    Kudos for Rao for all the hints he gave me to resolve the issue under this thread.

    Now, I am able to enjoy ZERO error testing :smileyhappy:


    Suggestion, packaging of SoapUI can be modified to avoid installing default plugins.



18 Replies

  • nmrao's avatar
    Champion Level 3
    That is strange. Which installer did you use(file name)? Please see if you have any such file (slf4j-xxxx.jar) under SOAPUI_HOME/lib directory.
    I could see that file under the same location.
    You may want to try fresh install again and see the error vanishes?
    • jrahman's avatar

      I installed from download page under

      The link was at Windows installer (32-bit).

      The name of the downloaded file was SoapUI-x32-5.2.1.


      Yes, under lib folder, I see there is a file named: slf4j-api-1.6.1.jar


      As you suggested, I'll try by uninstalling and re-installing and let you know.



      • jrahman's avatar

        Hello Rao (and friends following this thread):

        According to your suggestion, I have uninstalled and re-installed SoapUI 5.2.1 today.

        Sadly, the same error is reproducible.


        Note that, the host machine where SopaUI 5.2.1 has been installed is a brand new machine without any prior JAVA application running. As mentioned before, the Java version is found as:


        java version "1.6.0_26"
        Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
        Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode)


        Did you know why these errors occur ?