Forum Discussion

JamesZhou's avatar
New Contributor
13 years ago

Response HTTP/1.1 401 unauthorized

I ran in to a problem when using SoapUI 4.0.0 free version on Windows XP. When I go to run a test case(RESTful Get request,), it repeatedly returns 'HTTP/1.1 401 unauthorized',which makes me mad...I tried to do below actions after finding the resolutions from Board forum, but unfortunately it still doesn't work.
1) Input username and password respectively on Service Endpoints tab
2) Assign action for this Endpoint and also select 'All Request and Test Request'
3) Then checked "Adds authentication info to outgoing requests" next to "Authenticate Preemptively"

Post further details for this testcase scenario:
1) User input credentials username and password in systeem login page
2) Click a link to get a list of items

Hope this helps! Any help will be appreciated!

3 Replies

  • JamesZhou's avatar
    New Contributor
    I captured response header:
    Date Wed, 31 Aug 2011 13:01:21 GMT
    Content-Length 954
    #status# HTTP/1.1 401 Unauthorized
    Set-Cookie JSESSIONID=CCAAA7FC45306B3920875606292AE92E; Path=/
    Content-Type text/html;charset=utf-8
    Server Apache-Coyote/1.1
    Cache-Control no-cache
    • eshrestha's avatar

      Any help in this ? I am also getting  sam issue all the time even after giving username and password in authentication tab