Forum Discussion

jerry_007's avatar
New Member
6 months ago

Protocol family unavailable error using Github action


I'm facing a strange issue with the java HttpClient used by SoapUI. I run tests using the Soapui maven plugin to interact with an IPv6 webserver. Tests are performed in a Linux-based Github runner. IPv6 is well configured on that runner. The issue "protocol family unavailable" is raised by the httpClient when trying to connect to the webserver, but this appears only when Github starts and executes the workflow. If I manually run the tests on the runner through SSH, it perfectly works. I compared maven debug logs between the working and not-working tests, the jdk used is the same. I also tried to add options through the MAVEN_OPTS env variable as:

jdk.httpclient.HttpClient.log=all (to enable more logs from the httpclient, but no result)

but still the problem occurs. Do you have any clues on that topic?

Thanks for help


PS: proxy is disabled, see the attach settings file we use. The full backtrace is available in soapui-errors.log file

maven soapui plugin version: 5.0.0 / Apache Maven: 3.6.3 / Httpclient version: 4.1.1

No RepliesBe the first to reply